swiper.js IE11 動かない問題の対処法

ホームページをweb上にアップするにあたって、各ブラウザで確認していた所、IE11でswiper.jsが動かないということがあったのでこちらにまとめておきます。

最初は、swiper.js(6.3.3) を使用していました。

しかし、IE11でswiper.jsが動かない。他のブラウザでは動くのに、、、

IE11のみエラーが発生

swiper.min.css?ver=ver2.2s:13 Uncaught SyntaxError: Invalid or unexpected token

原因がわからず、色々検証してswiper.js(6.3.3)をswiper.js(5.4.5)にしてみたところ、

swiper.jsが動いてくれました!!

こちらからswiper.js(5.4.5)をダウンロードすることができます。

答えは簡単でした、swiper.js(5.4.5)以降はIE11では対応していなかったということです。

お困りのことがありましたら
お気軽にご相談ください

新メンバー募集中